Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

new setup cannot refresh allocation connection

Hi, tried everything, even going back to a clean reset of the files and i cannot seem to resolve a certain issue.

whenever i click, refresh all, I get the message that the connection :"worksheetConnection_PortfolioSlicerV2.3-XL13xlsx!Allocation" cannot be refreshed. MdxScript(Model) (6, 41) the syntax for 'tblstart' is incorrect.

any idea what this message means and how to resolve? many thanks.


  • You should very carefully review Allocation table in src worksheet and make sure there are no extra rows and that column names were not changed accidentally.
    If no issues found, then review Symbol table - make sure all Allocation values are valid.
    If you cannot find issue, you can send me your workbook, I'll review. If sending workbook, please also include files from PSData folder as I need them for refresh.
    My email is posted on this page:
  • Thanks for sending me your workbook.
    I believe the issue is with TargetPercent values.
    You specified values 10.0, 20.0, 30.0 - as decimal numbers. You need to change the format to integers. Please select all numeric values in this table and from Home menu, Number area select type "General".
    After that you should be able to do refresh. If you still have issues, please let me know.
  • thank you, I think I had made that change to ensure that there were no decimals lurking. unfortunately this did not solve the issue however.
    Also, i tried to enter the workbook connections dialog box and update each connection individually. the only one that updated was "thisworkbookdatamodel". all of the others gave the same error message: MdxScript (Model) (6, 41) The syntax for 'tblStart' is incorrect.
  • I am getting the same error message, even after following the advice in this thread. Was there ever a resolution for you?
  • Pelux,

    So for all issues where with incorrect data or data types. If you fix any data, try to refresh twice - first time you might still get error, but second time it should refresh without error. If you are still getting errors during refresh, you can send me your workbook and PSData folder content and I'll investigate. For privacy reason you can remove most of your transactions, but make sure that workbook you send me still have refresh error. Me email is posted on this page:
  • Pelux,

    In your Allocation data you still had numbers that were not integer (example 8.5) and this is not supported in the current version. I changed allocation percentages to integer values and did 2 refresh and all data was updated without any problems.
  • If you still are getting refresh errors:
    1. Check if your PSData folder is in c:\PortfolioSlicer
    2. Your workbook version is for Excel 2016 - please make sure you have Excel 2016 and not Excel 2013.
    3. Can you please post what error message are you getting?

  • Also, have you enabled "PowerPivot" in your Excel?
    From here:
    If you have Excel 2013 edition that has full PowerPivot support, you do not need to install PowerPivot add-in, but you might need to enable Power Pivot. For that you have to start Excel 2013, click on menu item "File" then "Options", then click on tab "Add-In". At the bottom of the screen from "Manage" drop down list select "COM Add-ins" and click "Go..." button. Make sure that check box by "Microsoft Office PowerPivot for Excel 2013" is checked and then click OK.
  • This issue is resolved, I was using the 2016 version file on a 2013 Excell install. I'm used to 2016 at work but have 2013 at home. thanks for all the help.
  • Pelux,

    Use PS file for Excel 2013 and you will be able to refresh it on Excel 2013 and 2016 without problems.
Sign In or Register to comment.