Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Historical data folder not updating

Hi Vidas,

For some reason, my historical data files are not updating. Intraday quotes appear to work fine.

Any suggestions?



  • Can you please send me:
    1. Your psConfig.txt file.
    2. Your files from Scripts\Logs folders.
    3. Your files from Quotes folder.

    My email is posted on this page:
  • I suspect that you have not updated your scripts. Could you please download latest scripts and run extract. Please let me know if that does not help.
  • Hi Vidas, I downloaded the scripts but when I run UpdatePSData.bat, I get the following:

    15:41:24 Script: Yahoo Historical . Quotes Requested/Succeed/Failed/Rows: 13/0/13/0. Duration: 4 sec.

    So it looks like it is telling me that the Yahoo Historical download has failed.
  • Now lets focus on one symbol - AMD that you requesting from Yahoo.
    1. Check in Quotes folder file _AMD_.txt - what is the latest date with quote for this symbol
    2. In Scripts/Log folder File GetQuotes-Yahoo.txt what is the line for symbol AMD?
  • Latest date for AMD is 2018-10-02.

    Symbol: AMD. Next date: 2018-10-03. Quote file: C:\Users\...\Portfolio Slicer\Quotes\_AMD_.txt
    Requesting url:
    AMD - Not Found (web err)
  • I just used your psConfig.txt and got data without problems. That lets me believe that your scripts are still not up to date. Could you please confirm what is the date on script GetQuotes-Yahoo.ps1? It should be 2019-05-31 or later.
  • It gives me 2019-10-05 3:37pm which is the date/time I had the previous files overwritten.

    I will try deleting the files instead of having them overwritten and see how it goes.
  • I deleted the previous files and placed the new scripts in the folder again, but I continue to get a failure with the yahoo historical update. This is so odd.
  • Try this:
    1. Delete scripts .ps1 file, leave other files in place.
    2. Go to download page and REFRESH page. Here is more info how:, but most likely CTRL+F5. You should see download version 2.4.12
    3. Download scripts extract them to some location and then copy them to your usual location from where you run scripts.
    4. Run extract.

    Let me know if you still having issues.
  • Thanks - I finally figured out the issue. The UpdatePSData.bat gave an error message that Internet Explorer's first-launch configuration is not complete.

    I don't use IE (and instead I use FireFox and Chrome) but once I set up Internet Explorer the first time, it finally gave me the historical quotes.
Sign In or Register to comment.