Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

error "table of multiple values where a single value was expected"


I am getting an error when i click on the "holdings" tab for some accounts and not others. The error basically states that it is unable to get a value for the equity as the program is deliivering a table of multiple values when a single value is expected. as i said, this only occurs for some accounts, not all. I must have some sort of error in the equities of those accounts. Has anyone run into this error previously?

The error reads '"Calculation error in measure 'Report'(equity value) A table of multiple values was dleivered where a single value was expected.



  • Could you please check if you have error.txt file in psdata folder. Also, what version of excel are you using?
  • Hello! Vidas Matelis,
    I am also getting same error. I use MS Excel 2016 64 bit version and Porfolioslicer V2.3. I checked PSData folder and couldn't find error.txt file. How to resolve this?

    Many thanks
  • Hi,

    Could you please send me:
    1. Info what Excel version you are using.
    2. Your Excel file. You can change data in Transactions there to preserve privacy, but it is important that with your changes you could reproduce error.
    3. Your psconfig.txt file
    4. All files from your c:\PortfolioSlicer\PSData folder.

    My email is posted on this page:
  • Hello Vidas,
    Thanks for your prompt reply.
    I had wrongly created two accounts with same name. I deleted the duplicate one and the problem is solved now. I can now refresh all reports.

    Thanks once again
  • Hello Vidas,

    I am getting the same error when I Introduded a second transaction adn try to refresh. Also, in hodlings, it doesnt do the account right. For example for BMA I have 105 shares and the last price was 128.00 ; Instead of making 105*128.00=13,440 it does 105-12,800=1,344,00.

    I dont have any error.txt file. Im using Excel 2016 on Windows 10 and the version of the PS is 2.3

    I attach the files you need, I had sent you the documents on my PSData folder earlier today
  • Hi alivabesil,

    I took your xlsx and used .csv files you send me before and I was able to refresh your data without any problems. So I have to assume that there is something wrong with your .csv files.
    Could you please first check if there is error.txt file created in your PSData folder. If no, could you please send me privately your .csv files that produce this error.
Sign In or Register to comment.