Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Stock Dividend updates

I am still using V2.4 and am noticing that the Dividends are not updating on some of the stocks. I did check Yahoo and there seems to be data but it not being pulled to update the files. I also did see some stocks are completely void of the Dividend info.
Has anyone else seen this happening.

Comments

  • @hheyermans I am noticing the same thing. It is not all stocks, but I noticed a drop off in dividends for April and May, compared to last year. Today, I noticed MSFT and ABST did not have their May dividend updated. I am using scripts from UpdatedScripts20220221.zip.
  • @hheyermans , @xcerik
    Could you please check your UpdatePSData.bat file (you need to edit it.
    It appears that in the release files line that calls GetDividends-Yahoo.ps1 script is commented out. So you just need to remove "REM " from that line, that is, probably in your script line is:
    REM powershell -ExecutionPolicy Bypass .\Scripts\GetDividends-Yahoo.ps1

    You need to change that to:
    powershell -ExecutionPolicy Bypass .\Scripts\GetDividends-Yahoo.ps1


  • Thanks for the quick reply @VidasMatelis. In my UpdatePSData.bat file, that line is not commented out. The last dividend the script found for me was on May 5. I'm still investigating.
  • edited June 28
    I tried adding Start-Sleep -Seconds 3 on line 34 of GetDividends-Yahoo.ps1, and I did get new dividend info for several symbols. Many still show "web err" in the log, but they may not have any new dividend info anyway.
    Script: Yahoo Dividends . Quotes Requested/Succeed/Failed/Rows: 102/16/35/12
  • I ran it again, with the same 3 second sleep, and got even better results, with only 5 failed.

    Quotes Requested/Succeed/Failed/Rows: 102/46/5/7
  • Yes, my UpdatePSData.bat file also did not have the command line Rem'd out.

    Can You (xcerik) provide where you entered the "Start-Sleep -Seconds 3" in line 34. Does it need to be added at the beginning of the line?
  • @hheyermans My issue seems to be caused by yahoo throttling. I have about 100 symbols and 50 symbols with dividends. By adding delays, I have been able to fetch dividend info without errors. If you see "web err" in Log\GetDividends-Yahoo.txt, there's a good chance Yahoo is blocking the request.

    Here is where I added the "sleep" in GetDividends-Yahoo.ps1 (on its own line):


    I also added a 100 second "sleep" in updatePSData.bat before the dividends:

  • @xcerik Thank you, I added the lines and I am now seeing some of the Web err being removed. I guess I need to pare down my list of symbols.
  • Sorry but how to see line numbers of the script file. Tried Notepad to edit but no line numbers are displayed.
  • .ps1 file can be edited with any text editor or with integrated PowerShell ISE. If you right mouse click on .ps1 file and choose "Edit", then you should see Windows PowerShell ISE open and you will see line numbers.
Sign In or Register to comment.