Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Query isn't executed

As you can see on the print screen, there is a little problem. This message comes up several time after I want to update the portfolio. It's in Dutch, but it says: "Query isn't executed or data model can't be opened. The following error message is returned: MdxScript(model) (16, 55) calculation error in measure 'Report'[Equity Value]: A table with multiple values was put in, whilst one value was expected.

I've nothing changed and it all started at November 1st. Last data transfer was on October 31st, everything worked well at that date.


  • Hi,

    I suspect that duplicate data come into Quotes table - could you please review it and then if you will find symbol with duplicate quote - please delete one row.
    You also have backup files in Quotes subfolder (so you can restore it if you need), then remove files and do full re-extract. This should help too.

    If above does not help, you can send me your Excel file and content of PSData folder and I will investigate. My email is posted:
  • edited November 2016

    Thank you for sending me your files. It appears that your problem is related to quotes.
    For each symbol in Quotes.csv file I would expect to have MONTHLY quotes from Min Date up to Today - 30days and then daily data from there.
    In your Quotes.csv file you have DAILY quotes from your MinDate up to 2016-09-15 and then no quotes and then just quotes for 2016-11-04 (probably from Yahoo intraday).
    So the question is where quotes for 2016-09-16 up to 2016-11-03 disappear? Please check symbol files in Quotes subfolder
    To make things even stranger - quotes you have already in the model include these missing dates.
    Is there any chance you changed hows Quotes.csv is created?
  • edited November 2016
    Well, one thing changed in last week of October, that was a brand new computer. But all data is stored on "One drive" except the csv files. They are gone now. I duplicated everything, not, but didn't think about these files. :blush:
  • So, are you all good now? Were you able to refresh?
  • Yes I was be able to refresh, but no, it's still the same. I deleted everything before refreshing, but no, it's not working.
  • Hi,

    Could you please send me:
    1. ps.Config.txt
    2. Zip content of your Quotes folder and subfolders.

    I will investigate and see where problem is.
  • Hi,

    I checked your data files and now all looks good - you have quotes for latest days. I believe you still have an issue just because of "residual data" in the data model.
    So do following:
    1. Make a copy of Excel workbook just in case you might need it.
    2. Open original Excel workbook.
    3. Start refresh - you will see a lot of error messages - just keep clicking OK till refresh will complete.
    4. Save workbook and close it.
    5. Open the same workbook again and then do data refresh. This time you will not see any error messages.
    6. If all works well, you now have Excel workbook that can be refreshed without errors.

    Please let me know if you still have any issues.

    When you refresh data in Excel 2013/2016, it happens in 2 separate phases. Data is read from csv files in one phase and from Excel linked tables in another phase. When you refresh and force through errors, you refresh data in data model to be consistent between csv and Excel file data and then second refresh works.
  • I did what you wrote here, several times, but it didn't work out. So, what now? Well, I've decided to download the latest version for office 2016 again from your site and transferred all the data in the new sheet. Also I refresh all data. I really don't know how, or why, but it is working so far. I have the sheet the way it was with all data till today. Thank you for your help, your great
  • Hi,

    It is good to know that you fixed your issue.
    As I said, I was able to refresh your Excel with your latest data using steps above. I was using Excel 2016. For anyone else having similar problems - on Excel 2013/2016 you also have option to do "selective table refresh" as described here: In case when you had issues with Quotes.csv file, I would try to refresh just Quotes table and see if that helps.
Sign In or Register to comment.