Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

script issue - help!

Can you tell me why I am getting this message?


  • XE is no longer allowing automated currency rate lookups.
  • Yes, XE removed scripted data extract option. I am waiting for Maxim to see if he can find another intraday currency exchange option.
  • Any progress regarding this issue ?
  • Sorry, no news yet.
  • Hi, Maxim send me scripts today, so I updated them - please download updates scripts from page.
  • Special thanks to Maxim and Vidas for continuously keeping this project up to date in a quickly changing world. We really appreciate all your efforts.
  • Vidas. Download page still shows May 11, 2018 update. Will that work?

  • Sorry, scrolled down further and now see.

  • Fixed, thanks guys !
  • Thanks Maxim and Vidas...
  • Hi Vidas,

    I have loaded the new scripts and have a problem when I run.

    The issue is that the scripts run and then hang after ExchRate YahooID as per the attached

    Your advice here would be welcome.

  • Hi,

    You have to figure out on what script you are getting stuck.
    Go to Scripts\Log folder and click on "Date Modified" column to sort by modified date. Check what is the script executed after GetExchRates-YahooIntraday.txt and then read that .txt log file - it should give you better information.
    You can also send me your log files and I'll look into this.
  • Vida, I have just sent through my log files for your consideration. Thanks :)
  • Based on the logs you send me, job is getting stuck on psArchiveOldQuotes script. This is because this script has just one line:
    07:45:05 --- Starting script psArchiveOldQuotes.ps1
    And there is no line with "Ending script..."

    DId you create some quote files manually? If so, please make sure that each file contains quotes just for one symbol!
    If you believe your quotes are good, then your options are:
    In the psConfig.txt file change parameter ArchiveQuotes from "Yes" to "No" and see if the script succeeds.
    This would be temporary fix, as PS performance is better when quotes are archived.
    So you would have to send me zipped (!) Quotes folder to me (including all subfolders) and I would investigate.

  • Thanks Vidas, yes I am guessing the psArchiveOldQuotes script is the issue.

    In respect of the quotes files, yes I am creating these manually. I went to this path because I was finding issues with the quality from Yahoo, google etc. My quotes files are on a daily basis and yes they contain multiple symbols, so from your observation this is possibly the issue. [I note that using an older script file I was not getting any issues other than the new issue identified above by the original poster.]

    I will revise my processes as I have heavily modified the PowerBI file to give me analysis that I was seeking. When I ran the new scripts with archiving the quotes my PowerBI has not responded well in results.

    At this point leave this with me and I will investigate further.

    Thank you for your time
Sign In or Register to comment.