Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Report Capital Gain % error

I been trying to figure what this error is for a week now but no luck. I have multiple accounts and none of them have an error except for one where I have pin point the issue to.

If I add a new transaction against this account, it would give me the Report Capital Gain % error, once I remove that transaction, there is no error.



I noticed in the Overview tab, I see the Cap gain % as -94.70% which isn't right, I think the new transaction push it over -100% which cause the error? I looked all all the transaction and i don't see how it could have calculated -94.70%.


«1

Comments

  • This might be something for you to confirm:

    Do the dates you are using for your transactions in the "srcTrans" Tab, clearly fall INSIDE the date range of PortfolioSlicer's DataModel? You can check the start date of the DataModel in cell A4 located in tab "src", the End date of the DataModel is the most recent "Data Refresh" date.
    As an example of what I'm thinking here is, if your problem involves a monthly calculation, the program should be trying to work with a full month worth of data .... (I am sort of guessing here)
  • buddyb is pointing you to the right direction - make sure that your Date field is "reasonable" one and also make sure that you have quotes for that symbol UP TO THE date you enter transaction.
  • edited May 24
    I'm entering all the buys from May 3, 2022, the previous entries for this same day have no issue. The same stock is also being hold by other accounts and their account is not effected.

    Below is when it starts to cause the error when i add HCAL, I tried to add other stock buy and again same error. So something is causing this issue of not allowing me to add anymore entries to this account.


  • Are you tracking cash? If so, what is CashBalance value for this last transaction? It must be 0 or positive value, NOT NEGATIVE!
  • Account is active and working .. (check)
    Symbol is active and working .... (check) (plus it is purple colored)
    Something is still "Funny" ... (check)

    Try this:
    INSERT a row in the table where you know it is working ... Say below row #807
    Manually enter your transaction from Row #819 into the new row #808. (you may have to drag equations
    down from Row #807 into #808, if it does not do it automatically)
    Delete row #819
    Refresh and see if things work.

    It things "work", then check all the equations in each of the columns of the table.
    Each column has the same "equation", except possibly a relative position cell effect.
    If you find a different looking equation, just DRAG the equation down from a cell above the noticed change.
    (Be sure to be using a copy of your workbook when you start digging into the data Tables like this).

    I find PS to be quite a stable software package, What you are describing here is very unusual, so in these cases, I usually find the problems to be very, very simple, and easily overlooked. (This is seen AFTER hindsight kicks in)

    This can be fixed.
  • @VidasMatelis not tracking Cash, first thing I check to ensure it wasn't turn on by mistake.

    @buddyb thanks for the suggestion but it didn't work :(




    Also tried to just copy down the formula and still no go.

    But if I change the account WS-SHIRL-TFSA to any of my other account and refresh the data, there is no error. So I'm not sure what wrong with this WS-SHIRL-TFSA account, since it new and only have these following transactions.
  • Could you send me your workbooks and flat files in PSData folder so I could refresh? My email is posted on this page: http://www.portfolioslicer.com/contact.html
    For your privacy, you can remove other account information, just make sure that the version you send me I can reproduce the problem.
    This is very strange error that I cannot figure out without seeing data.
  • Thanks Vidas, sent.
  • Another kick at the can:

    Maybe the problem is with the Account name. (a hidden character perhaps?)
    Try going to the src Tab, select and COPY the account name there, and paste it in the srcTrans Tab.
  • I don't think that is the issue cause I copy the row where the issue didn't appear into the new row and the error happen again.
  • zzriecezz - I did not get an email with you - please check if you send it.
  • @VidasMatelis it was sent to PortfolioSlicer@gmail.com at 10:14am today using gmail.
  • zzricezz - confirming receipt, it was marked as spam and that is why not forwarded.
    I will look into this later tonight.
  • This is a strange problem. I believe issue is with one transaction - large quantity purchase of GRN.TO. Can you please do test on your environment - for GRN.TO transaction that buys 5500 - can you please change in srcTrans table quantity to 550 and try refreshing.
  • Changed it to 550 did not help, same error.
Sign In or Register to comment.